Minix Man Pages

Man Page or Keyword Search:
Man Architecture
Apropos Keyword Search (all sections) Output format
home | help
KYUA-TESTER-LIST(5)         BSD File Formats Manual        KYUA-TESTER-LIST(5)

NAME
     kyua-tester-list -- The test cases list printed by the Kyua testers

SYNOPSIS
     test_case(properties_table);

DESCRIPTION
     The 'list' subcommand of the various Kyua testers outputs the list of
     tests cases within a given test program.  The format of the list of test
     cases is a Lua script in which every line invokes the test_case()
     function to define a test case.  The kyua(1) runtime engine reads this
     list in order to determine what tests can be run.

     The test_case() function takes a table as its only argument, and the
     table contains the definition of the metadata properties of the test
     case.  A typical invocation of this function looks like this:

     test_case{name='THE-NAME', ...}

     Where '...' denote optional metadata values attached to the test case.
     The supported metadata properties are the following:

     allowed_architectures    Whitespace-separated list of machine
                              architecture names allowed by the test case.  If
                              empty or not defined, the test case is allowed
                              to run on any machine architecture.

     allowed_platforms        Whitespace-separated list of machine platform
                              names allowed by the test case.  If empty or not
                              defined, the test case is allowed to run on any
                              machine platform.

     description              Textual description of the test case.

     has_cleanup              If 'true', denotes that the test case has a
                              cleanup routine.

     required_configs         Whitespace-separated list of configuration
                              variables that the test case requires to be
                              defined before it can run.

     required_files           Whitespace-separated list of paths that the test
                              case requires to exist before it can run.

     required_memory          Amount of physical memory that the test case
                              needs to run successfully.

     required_programs        Whitespace-separated list of basenames or
                              absolute paths pointing to executable binaries
                              that the test case requires to exist before it
                              can run.

     required_user            If empty, the test case has no restrictions on
                              the calling user for it to run.  If set to
                              'unprivileged', the test case needs to not run
                              as root.  If set to 'root', the test case must
                              run as root.

     timeout                  Amount of seconds that the test case is allowed
                              to execute before being killed.

     X-NAME                   Custom variable defined by the test case, where
                              'NAME' denotes the name of the variable.

SEE ALSO
     kyua-atf-tester(1), kyua-plain-tester(1)

BSD                            December 26, 2012                           BSD

NAME | SYNOPSIS | DESCRIPTION | SEE ALSO