Minix Man Pages

Man Page or Keyword Search:
Man Architecture
Apropos Keyword Search (all sections) Output format
home | help
KYUA-BUILD-ROOT(7)   BSD Miscellaneous Information Manual   KYUA-BUILD-ROOT(7)

NAME
     build-root -- Mechanics of build directories

DESCRIPTION
     Build directories (or object directories, target directories, product
     directories, etc.) is the concept that allows a developer to keep the
     source tree clean from build products by asking the build system to place
     such build products under a separate subtree.

     Most build systems today support build directories.  For example, the GNU
     Automake/Autoconf build system exposes such concept when invoked as
     follows:

           $ cd my-project-1.0
           $ mkdir build
           $ cd build
           $ ../configure
           $ make

     Under such invocation, all the results of the build are left in the
     my-project-1.0/build/ subdirectory while maintaining the contents of
     my-project-1.0/ intact.

     Because build directories are an integral part of most build systems, and
     because they are a tool that developers use frequently, kyua(1) supports
     build directories too.  This manifests in the form of kyua(1) being able
     to run tests from build directories while reading the (often immutable)
     test suite definition from the source tree.

     One important property of build directories is that they follow (or need
     to follow) the exact same layout as the source tree.  For example,
     consider the following directory listings:

           src/Kyuafile
           src/bin/ls/
           src/bin/ls/Kyuafile
           src/bin/ls/ls.c
           src/bin/ls/ls_test.c
           src/sbin/su/
           src/sbin/su/Kyuafile
           src/sbin/su/su.c
           src/sbin/su/su_test.c

           obj/bin/ls/
           obj/bin/ls/ls*
           obj/bin/ls/ls_test*
           obj/sbin/su/
           obj/sbin/su/su*
           obj/sbin/su/su_test*

     Note how the directory layout within src/ matches that of obj/.  The src/
     directory contains only source files and the definition of the test suite
     (the Kyuafiles), while the obj/ directory contains only the binaries
     generated during a build.

     All commands that deal with the workspace support the --build-root path
     option.  When this option is provided, the directory specified by the
     option is considered to be the root of the build directory.  For example,
     considering our previous fake tree layout, we could invoke kyua-test(1)
     as any of the following:

           $ kyua test --kyuafile=src/Kyuafile --build-root=obj
           $ cd src && kyua test --build-root=../obj

SEE ALSO
     kyua(1), kyua-debug(1), kyua-list(1), kyua-test(1)

BSD                            September 9, 2012                           BSD

NAME | DESCRIPTION | SEE ALSO